Troubleshooting

From SpareMiNT Wiki
Jump to: navigation, search

If you encounter a FreeMiNT/XaAES related problem and find a solution to it, please document it in this guide.

Contents

Wrong XaAES is loaded after upgrading

If you're using a standard EasyMiNT-setup, it will start /usr/bin/xaloader. This is a symbolic link to the actual xaloader.prg located in the system folder. However, this link is static, so when you upgrade to a newer kernel that requires a new system folder, the symbolic link needs to be updated to point to the new xaloader.prg. If you don't do this, the old XaAES will still be loaded.

rm /usr/bin/xaloader
ln -s $SYSDIR/xaaes/xaloader.prg /usr/bin/xaloader

XaAES doesn't work with NVDI ET4000

Problem: XaAES hangs during start-up when NVDI is used as a driver for ET4000 graphics cards.

Solution:

Method 1: Make a symlink from c:\auto to u: e.g.: mint.cnf: sln c:\auto u:\auto (not necessary since XaAES 1.8.4). Make sure sclt_dev.prg is executed during boot (reason yet unknown). video may remain unset. Do not set et4000_hack! Verified with nvdi-et4000 v4.11 in 8 and 15 bit-video and a CrazyDots-VME-card.

Method 2: Boot to the TOS desktop (GEM=ROM in mint.cnf) and start XaAES from the desktop by running xaloader.prg. To automate the boot-process it is possible to install xaloader.prg as autostart-application in the ROM-desktop. video-setting ignored. verified with nvdi-et4000 v4.11 in 8 bit-video and a CrazyDots-VME-card. This works with XaAES since version 0.999. It is recommended to install 2(!) accessories for this (e.g. xcontrol and st-guide). Memory-protection should be off.


XaAES doesn't work with the Eclipse graphics card

Problem: XaAES hangs during start-up when the Eclipse graphics card is enabled.

Solution: This happens when fVDI alone is used to drive the Eclipse. Use NVDI as well, XaAES will now start correctly. Make sure that both fVDI and NVDI runs before FreeMiNT in the autofolder. fVDI must be started before NVDI.


Serial port does not work/is slow

Problem: The serial port is not working, or it's slow and unreliable.

Solution: If you haven't used FreeMiNT before, there's a good chance that you have the HS-Modem serial port drivers installed. Remove these. FreeMiNT has it's own, high-perfomance drivers and HS-Modem will only interfere with these.


Serial mouse does not work any more

Problem: You have a serial mouse connected using the driver from genmouse that works under plain TOS, but not under MiNT.

Solution: Disable the serial driver from MiNT that the mouse-driver uses. For example, if the serial mouse is plugged into Modem1, disable mfp.xdd by renaming or removing.


Programs in the auto-folder are not executed

Problem: There are programs in the autofolder that runs normally when starting TOS, but does not run at all when booting FreeMiNT.

Solution: Programs that are located after mint.prg in the autofolder will only be started if Execute AUTO PRGs: is set to yes in the boot-menu.


Desktop accessories are not loaded

Problem: Desktop accessories are loaded by TOS, but not by XaAES.

Solution: TOS loads accessories from the root of the boot-drive. Make sure that XaAES is set up to find accessories at this location (see the ACCPATH setting in xaaes.cnf).


Personal tools
Resources